Requirements

Supported Web Browsers

Firefox

firefox

Google Chrome

chrome

Safari

safari

Internet Explorer

ie

Unsupported Browsers

While DENSO Auto Care might run without major issues in older browser versions, we do not actively test in them and generally do not fix bugs that may appear in them.

Supported Platforms

Microsoft Windows

Java required, IE8 has some display issues but has been tested to function.

Mac OS X

Java required, VitalScan may not run.

PDF Viewer

To view PDF files, you'll need a PDF viewer such as Adobe Acrobat, FoxIt Reader (Windows), Skim (Mac), or Preview (Mac).

Java

In order to run the VitalScan portion of the DENSO Auto Care web site, you will need to have the latest version of Java installed. Click here to download and install on your computer.

USB 2.0

Your computer must have at least one USB 2.0 port (typically computers made after 2005 will have USB 2.0 ports). Newer computers built after 2010 will usually have USB 3.0 connectors, which are compatible with USB 2.0.

Mobile Devices (iPhone/Android/iPad)

Mobile devices are supported to view. However, the VitalScan portion requires Java and thus reports cannot be generated. You can view reports and the remaining site will function correctly.